EFFECTIVE JANUARY 1, 2018

UPS REQUIRES JDA PARCEL CUSTOMERS TO BE COMPLIANT WITH TLS 1.2 SECURITY STANDARDS

Time is running out for JDA Parcel customers who ship via UPS to meet TLS 1.2 Security Standards requirements. Are you ready?

Ascenion Logistics has the resources and know-how to manage the installation and execution of the necessary patch for compliance. You don’t have time for this… let Ascension handle it.

Ascension Logistics can:

  • Manage and execute the necessary support tickets and patches for customers with JDA Parcel versions 2010.1 through 9.1.0.0
  • Manage and execute the required migration to JDA Parcel version 9.1 for JDA customers with JDA Parcel versions2009.2 or earlier, and subsequent support and patches for compliance

TICK TOCK.

CONTACT US »